Project

General

Profile

Feature #2144

Feature #1805: add missing UI method support

add minimum runtime support for methods (server)

Added by Greg Shah almost 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Vadim Gindin
Start date:
Due date:
% Done:

0%

Estimated time:
32.00 h
billable:
No
vendor_id:
GCD

vig_upd20140811a.zip (9.76 KB) Vadim Gindin, 08/11/2014 01:29 PM

vig_upd20140811b.zip (9.78 KB) Vadim Gindin, 08/11/2014 04:42 PM

History

#1 Updated by Greg Shah almost 11 years ago

  • Estimated time set to 32.00
  • Due date set to 08/27/2013
  • Assignee set to Constantin Asofiei
  • Start date set to 08/22/2013

#2 Updated by Greg Shah about 10 years ago

  • Start date deleted (08/22/2013)
  • Due date deleted (08/27/2013)
  • Assignee changed from Constantin Asofiei to Vadim Gindin

Implement runtime support for DESELECT-ROWS and MOVE-BEFORE-TAB-ITEM. Please put all history entries in the parent task (#1805).

#3 Updated by Greg Shah over 9 years ago

  • Status changed from New to Closed

#4 Updated by Vadim Gindin over 9 years ago

During the work on that task I found that DESELECT-ROWS is already implemented and only some error checking was needed. I added that check. All other big work was made for MOVE-BEFORE-TAB-ITEM. At the end of work on that task I forgot to commit changes for DESELECT-ROWS. Here is the update for with these changes.

#5 Updated by Greg Shah over 9 years ago

Code Review 0811a

1. This code needs null protection since query can be null.

      if(!query.isOpen().getValue() || query.getNumResults().intValue() == 0) {

2. Doesn't the inclusion of the . (2108) into the error string cause this portion to be "doubled up" in the resulting output?

         String msg = "Browse widget must contain at least one record before DESELECT-ROWS method is used. (2108)";

3. There should be a space between the if and the following ( in 2 places.

4. The opening { needs to be on its own line.

#6 Updated by Vadim Gindin over 9 years ago

next update with corrections

#7 Updated by Greg Shah over 9 years ago

Code Review 0811b

I am fine with the changes.

#8 Updated by Vadim Gindin over 9 years ago

passed regression testing and committed with rev 10596.

#9 Updated by Greg Shah over 7 years ago

  • Target version changed from Milestone 11 to Cleanup and Stablization for Server Features

Also available in: Atom PDF