Project

General

Profile

Bug #2291

Could not resolve closest legacy method for function returning an extent

Added by Hynek Cihlar almost 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
04/24/2014
Due date:
% Done:

100%

billable:
No
vendor_id:
GCD
case_num:

ProcedureManager.java.diff Magnifier (639 Bytes) Hynek Cihlar, 04/24/2014 02:22 PM

hc_upd20140424a.zip (17.3 KB) Hynek Cihlar, 04/24/2014 03:02 PM

hc_upd20140425a.zip (17.3 KB) Hynek Cihlar, 04/25/2014 01:12 PM


Related issues

Related to Base Language - Bug #2133: fix precision for decimal, dynamic-extent variables Closed 01/21/2014 01/27/2014

History

#1 Updated by Hynek Cihlar almost 10 years ago

Calling a function of extent return type is causing the error "Could not resolve closest legacy method for class XYZ".

The problem seems to be in ProcedureManager in the method resolveClosestMethod. The logic there expects a method ending with the string "function" in its name on the Java callstack. And because it compares the strings case-sensitively it fails in case of the extent-function - in which case there is "extentFunction" on the callstack.

I am attaching a fix which seems to work ok.

#2 Updated by Constantin Asofiei almost 10 years ago

Hynek Cihlar wrote:

I am attaching a fix which seems to work ok.

OK, leave only the function related change, the procedure compare can be done case-sensitively.

#3 Updated by Hynek Cihlar almost 10 years ago

Please review.

#4 Updated by Hynek Cihlar almost 10 years ago

  • Status changed from New to Feedback

#5 Updated by Constantin Asofiei almost 10 years ago

The change is OK, no regression testing is required. But before releasing it, make sure the code respects the 98-chars width limit for lines. It should look something like this:

         if (cname.equals(bmClass)&& 
             ((function && mname.toLowerCase().endsWith(funcApi)) || 
              (!function && mname.equals(procApi))))

#6 Updated by Hynek Cihlar almost 10 years ago

Attached is the final change with the fixed code formatting. Committed into bzr revision 10516. No regression test run.

#7 Updated by Hynek Cihlar almost 10 years ago

  • % Done changed from 0 to 100

#8 Updated by Greg Shah almost 10 years ago

  • Target version set to Milestone 11
  • Status changed from Feedback to Closed

#9 Updated by Greg Shah over 7 years ago

  • Target version changed from Milestone 11 to Cleanup and Stablization for Server Features

Also available in: Atom PDF